Customers are able to launch games. - Service has been restored

Incident Report for NVIDIA GeForce NOW

Resolved

This incident has been resolved.
Posted Sep 16, 2025 - 12:29 PDT

Update

We are continuing to monitor for any further issues.
Posted Sep 14, 2025 - 10:57 PDT

Update

All issues have been resolved and all features are functioning.
Posted Sep 13, 2025 - 10:41 PDT

Monitoring

We continue to monitor our services closely post the recent service issue. We are investigating an issue where feature flags on games (RTX, HDR, Reflex, ...) are not visible in the client. RTX can be enabled in game for RTX enabled games.

Please read this knowledge base article for information on membership compensation related to the service interruption.

https://nvidia.custhelp.com/app/answers/detail/a_id/5714
Posted Sep 12, 2025 - 18:17 PDT
This incident affected: NVIDIA Global Services.