GeForce NOW 1-month Premium, Day Pass memberships Sold Out in Japan.
Incident Report for NVIDIA GeForce NOW
Resolved
This incident has been resolved.
Posted Sep 03, 2024 - 11:53 PDT
Monitoring
Due to increased demand, GeForce NOW 1-month Priority and Ultimate memberships are currently sold out in Japan. Priority and Ultimate Day Passes are also sold out.

To help with capacity, free membership sign ups have also been paused. This does not impact current members.

Join the waitlist at www.geforcenow.com to have first access when these memberships are available. Six-month premium memberships are still available.
Posted Aug 13, 2024 - 16:57 PDT
This incident affected: JP East [RTX 4080 Ready] [Sold Out] (NP-TYO-01 [RTX 4080] [Sold Out]).